Моя корзина Моя корзина
Сейчас корзина пуста.

Мой профиль
Главная | Требования к хостингу

Требования к хостингу

Система управления «SX» не требовательна к ресурсам и не требует специализированных хостингов и выделенных серверов, требования системы минимальны и доступны на большинстве современных хостингов.

Основные технические требования:

Для «SX» CMS должны быть установлены следующие компоненты:

  • ОС Windows/Unix (или совместимые) *
  • Веб-сервер Apache *
  • Препроцессор PHP версии 5.1.2 и выше *
  • СУБД MySQL 4.1.3 и выше *
  • Библиотека SPL *
  • Библиотека MySQLi *
  • Графическая библиотека GD *
  • Библиотека iconv *
  • Библиотека Zlib *
  • Библиотека libxml
  • Поддержка локали ru_RU.CP1251 *
  • Библиотека mbstring * (для версий старше 1.03)


Для веб-сервера Apache должны быть установлены следующие компоненты:

  • Модуль mod_rewrite
  • Модуль mod_expires
  • Модуль mod_header


Для препроцессора PHP должны быть установлены следующие директивы:

  • safe_mode: неактивно
  • register_globals: неактивно
  • magic_quotes_gpc: неактивно
  • magic_quotes_runtime: неактивно
  • magic_quotes_sybase: неактивно


Дополнительная информация:

  • Для корректной работы системы необходимо, чтобы PHP работал от имени системного пользователя, которой является владельцем корневой директории сайта, а также имеются права для записи в корневую директорию без дополнительных манипуляций с настройками.
  • Для выполнения некоторых системных операций по обслуживанию в панели управления, необходимо, чтобы на сервере отсутствовали ограничения на время выполнения PHP-скриптов. Требуемое время зависит от выполняемой операции и объема данных, но ограничение по крайней мере не должно быть менее 30 секунд.
  • Требования к выделяемой процессу PHP памяти зависят от установленных модулей и блоков. Минимально необходимая память 16Мб, рекомендуемая - 32Мб. Система потребляет память только при необходимости, по этой причине выделение большего количества памяти не создает избыточного потребления системных ресурсов.


Для выяснения, подходит ли хостинг для функционирования «SX» CMS, необходимо просто отправить запрос в службу технической поддержки хостинг-провайдера с просьбой дать комментарии к представленному списку технических требований.


Для работы в панели управления необходим веб-браузер:

  • Internet Explorer версии 7.0 или выше
  • Mozilla Firefox версии 3.0 и выше
  • Opera версии 9.0 и выше
  • Google Chrome любой версии
  • Apple Safari версии 3.2 и выше


*  - обязательный параметр





  Оценка  

Связанные статьи

Вы не можете комментировать!
Печать | Copyright © 2009 - 2017 Status-X All rights reserved | Powered by CMS Status-X 1.05 | Контакты